Replaced battery then code 15

Alternator, waterpump, A/C, sensors, CAS, etc.

Moderators: theelanman, dapinky, Nige, Elanlover, Sy V, muley, Enright, algirdas, nitroman, GeoffSmith, clemo, Dave Eds, Specky, DaveT

Replaced battery then code 15

Postby Kipperozzy » Wed 12.01.2022, 20:18

Currently Elan sorned for the winter, in lockup connected to CTEK low power charger. Went in the other week and door wouldn’t open remotely so opened by key and no interior light. Battery was totally flat, the charger didn’t even think it was connected, date on battery was 2013 so fitted replacement. Wasn’t too much bother as forward clamp bolt hole was slotted.
Car started up ok and run it up till the rad fans came on. A week later, started car and after a minute the amber CEL came on and then engine started hunting and wouldn’t Rev up, eventually died and wouldn’t restart. Next day engine started first time and then started hunting again, so switched off and read the forum before ordering new CTS from Kelvedon, £ 24 inc delivery.
Fault code 15 so ordered a new CTS and antifreeze, fitted today, I moved the spark plug leads and rubber EGR pipe out of the way and removed with a deep 19 mm socket. Refilled with new antifreeze and car runs great again :D
Thank goodness for onboard diagnostics !
PS the resistance of the old CTS was 400k ohms and new one 3400 ohms
Kipperozzy
Enthusiast
 
Posts: 183
Joined: Wed 09.03.2016, 15:14
Location: Greenock, Scotland

Re: Replaced battery then code 15

Postby Rambo » Wed 12.01.2022, 20:27

Glad you're sorted Kipperozzy and managed to do your own self diagnosis. It's very satisfying when you can sort a problem out. There seem to have been quite a few CTS problems recently :?
Rambo
Don't push me
 
Posts: 8710
Joined: Wed 24.12.2003, 00:37
Location: Both sides of the Tweed


Return to Engine Ancillaries

Who is online

Users browsing this forum: No registered users and 1 guest