ECU to borrow/buy

Moderators: theelanman, dapinky, Nige, Elanlover, Sy V, muley, Enright, algirdas, nitroman, GeoffSmith, clemo, Dave Eds, Specky, DaveT

Re: ECU to borrow/buy

Postby texas2201 » Thu 18.06.2020, 17:10

dapinky wrote:
texas2201 wrote:Yeah I can do that - I had it off when I put the new coil packs on about 2 months ago. No harm doing it again.....well when the rain stops :-(


Ah, a quick thought, if you have been in that area recently.... when you changed the coils did you fit the screws correctly? There is a small nylon washer which electrically isolates the mounting plate (item 13/14 from this page in the parts manual)....... without them, there can be a few issues with bits of the car having a different earth voltage which wouldn't help.

Untitled.jpg


Cannot remember exactly but I put it all back as it had come off I will check it in the morning when I take it off
"brakes are no good - they just slow you down" Fangio :-)
User avatar
texas2201
God
 
Posts: 1346
Joined: Fri 30.06.2006, 17:24
Location: Boos Eifel Germany

Re: ECU to borrow/buy

Postby texas2201 » Fri 19.06.2020, 13:37

OK - joy of JOYS.......

Took out the coil packs and backing plate - cleaned surfaces and earth - nothing to bad. Refitted

Adjusted CAS slightly and went for a test run - no stuttering, no backfires, smooth boost....even to .9..... :-)

log attached - I forgot to clear the codes so the code 300 is probably the one from yesterday?

Does this mean I have bought an ECM when I did not need to? Anyone need a Lotus Elan SE ECM :-)

I have also bought a Hall Sensor and thermostat - but it is probably wise to keep these as the Hall sensor was replaced many years ago

Should I still get the base timing done at the garage?
You do not have the required permissions to view the files attached to this post.
"brakes are no good - they just slow you down" Fangio :-)
User avatar
texas2201
God
 
Posts: 1346
Joined: Fri 30.06.2006, 17:24
Location: Boos Eifel Germany

Re: ECU to borrow/buy

Postby texas2201 » Tue 21.07.2020, 21:08

Update... Just had the timing done and Elan is running sweet again. So I have a spare ECM which is for sale now ......

Just got to get elanscan onto a mates laptop. Left mine in the UK... DOH
"brakes are no good - they just slow you down" Fangio :-)
User avatar
texas2201
God
 
Posts: 1346
Joined: Fri 30.06.2006, 17:24
Location: Boos Eifel Germany

Re: ECU to borrow/buy

Postby texas2201 » Thu 27.10.2022, 12:40

newish problems - cannot get elanscan cable to talk to ecu - bad echo - no response - checked the com port latency and set it to 1 - still no good - paper clip reads 12 - no problems


however, on partial throttle i am getting a symptom of "stutter" or fuel cutoff.... I have ordered a speed sensor for the back of the speedo and will fit it when it arrives

if anyone has any ideas about getting the cable to work please post

laptop has been into the repair shop for new battery and charging port - they checked the comm port and all OK. I also had another technician check it as well and clean bill of health. Device manager also says it is working fine?

The cable did work before as you can see from the logs I posted earlier in the thread.....
"brakes are no good - they just slow you down" Fangio :-)
User avatar
texas2201
God
 
Posts: 1346
Joined: Fri 30.06.2006, 17:24
Location: Boos Eifel Germany

Re: ECU to borrow/buy

Postby TorqueHorse » Thu 27.10.2022, 14:47

I had a similar issue where I got a "12" from the paper clip, yet couldn't get anything from the cable in ElanScan. I ended up getting a new ECU and then that does work on the cable (closed loop ones were still available from Bell & Coville for under $200 last I checked). Even with the new ECU though, sometimes the actual USB connection to the computer gets loose, and it loses signal, so you might check wiggling it around.
'90 FED M100 -mid resto
Chassis Exterior FrSus RrSus Engine Trans Wheels Steering Brakes Cooling Fuel Ventilation Exhaust Interior
User avatar
TorqueHorse
Fanatic
 
Posts: 438
Joined: Wed 01.01.2020, 07:42
Location: Austin, TX

Re: ECU to borrow/buy

Postby texas2201 » Fri 28.10.2022, 04:48

TorqueHorse wrote:I had a similar issue where I got a "12" from the paper clip, yet couldn't get anything from the cable in ElanScan. I ended up getting a new ECU and then that does work on the cable (closed loop ones were still available from Bell & Coville for under $200 last I checked). Even with the new ECU though, sometimes the actual USB connection to the computer gets loose, and it loses signal, so you might check wiggling it around.


Thànks I fitted a new ecu as well and tried wiggling the cable as well :-(
"brakes are no good - they just slow you down" Fangio :-)
User avatar
texas2201
God
 
Posts: 1346
Joined: Fri 30.06.2006, 17:24
Location: Boos Eifel Germany

Previous

Return to Engine

Who is online

Users browsing this forum: No registered users and 1 guest