Hello from Prestwick, Ayrshire.

A forum where new members can introduce themselves and be welcomed by existing members.

Moderators: theelanman, DaveT, GeoffSmith, Elanlover, Nige, muley, Enright, Sy V, algirdas, Specky, nitroman, clemo, dapinky, Dave Eds

Hello from Prestwick, Ayrshire.

Postby ColinBruce » Sun 04.03.2018, 19:11

Hi, I became a member a few a few weeks ago but I haven't had the time to introduce myself properly until now.
Thanks to Scott J, John_W, Jamie N & Clemo who have already contributed in a post called Monte Carlo Rally Paisley. You seem like a friendly bunch.

This week I have fitted a set of winter tyres on white rally-style 5 spoke alloys. I could use these all year round but plan to keep them for winter navigation rallies. The next modification planned is a LED light bar which will make a huge difference on nighttime events but I expect it will be into the summer before I get around to this.

My Elan now has a cherished number but came with H97OOF. When I bought it nearly 3 years ago the engine didn't run well and sometimes even cut out. Eventually my local garage discovered that the rotor in the distributor had not been fitted properly which was causing the timing to randomly change! I don't know for how long or for how many owners the car had been like that. However - it's all sorted now. I also removed the turbo dump valve as it was a bit 'boy-racery' for me and sounded like the car was sneezing every time I changed gear!!! If anyone knows any history on this car then please get in touch.
ColinBruce
Newbie
 
Posts: 4
Joined: Sun 04.02.2018, 15:18

Re: Hello from Prestwick, Ayrshire.

Postby lotusflasherman » Sun 04.03.2018, 19:42

Well you've got me signing onto confused.com. If it''s an SE with turbo, you mention dump valve, it will have a cam angle sensor and ignition timing is mainly controlled by the Engine Control Unit - the electronic box hidden behind the glove box. Don't know why your garage is talking about a distributor and rotor arm problem as it hasn't got one to have a problem :smt017
Phil

Leave me alone, I think I know what I'm doing.
Cars: Subaru Forester 2.5XTN, Eclat Riviera & brace of Pacific Blue SE's.... and now an Elan+2S !
User avatar
lotusflasherman
God
 
Posts: 2131
Joined: Fri 05.09.2008, 00:14
Location: Hadleigh, 15m west of Ipswich or 800 miles south (Cap d'Agde)

Re: Hello from Prestwick, Ayrshire.

Postby Rambo » Sun 04.03.2018, 21:31

Must be one of those slower N/A's Phil :?
User avatar
Rambo
Goldfish-brain
 
Posts: 6187
Joined: Wed 24.12.2003, 00:37
Location: Peebles

Re: Hello from Prestwick, Ayrshire.

Postby Kipperozzy » Sun 11.03.2018, 18:22

Hello Colin, welcome aboard it’s good to see another Elan on the West Coast, and Prestwick didn’t get as much snow as us. I had to dig my way into my garage last weekend. I think I picked a good winter to SORN mine to recoat all the metalwork as the roads this year have been very salty here in Greenock
Kipperozzy
Tinkerer
 
Posts: 74
Joined: Wed 09.03.2016, 15:14
Location: Greenock, Scotland

Re: Hello from Prestwick, Ayrshire.

Postby ColinBruce » Sun 22.04.2018, 14:27

Hi Lotusflasherman & Rambo. Yes I do seem to have confused both of you and it is completely my fault. When I wrote about the distributor not being put back together properly by a previous owner I should have said the cam angle sensor. Forgive me, I am not a mechanic and to my simple way of thinking it does pretty much the same job.
ColinBruce
Newbie
 
Posts: 4
Joined: Sun 04.02.2018, 15:18

Re: Hello from Prestwick, Ayrshire.

Postby Rambo » Sun 22.04.2018, 16:21

No problems Colin. At least you have a proper Elan with a CAS :twisted:

Hope you're enjoying the roads in Ayrshire this balmy spring :burnout:
User avatar
Rambo
Goldfish-brain
 
Posts: 6187
Joined: Wed 24.12.2003, 00:37
Location: Peebles


Return to New Members - Introductions

Who is online

Users browsing this forum: No registered users and 1 guest