I made a mistake

Alternator, waterpump, A/C, sensors, CAS, etc.

Moderators: theelanman, dapinky, Nige, Elanlover, Sy V, muley, Enright, algirdas, nitroman, GeoffSmith, clemo, Dave Eds, Specky, DaveT

Re: I made a mistake

Postby GeoffSmith » Tue 04.05.2021, 10:49

Also the NA ECU circuit diagram is here:
http://wikilec.com/images/8/83/MJ25-03_ ... 8NA%29.gif
Calypso Red S2 #417

USB ElanScan interfaces - £60 incl. UK P&P & £65 incl. ROW P&P
User avatar
GeoffSmith
Kitty Fiddler
 
Posts: 15344
Joined: Fri 03.02.2006, 21:57
Location: S2#417 in Tytherington, Gloucestershire

Re: I made a mistake

Postby GeoffSmith » Tue 04.05.2021, 10:51

Rambo wrote:It does say ECM (turbo) though

It's only the turbo that has the sense line connected back from the fuel pump (I believe).
Calypso Red S2 #417

USB ElanScan interfaces - £60 incl. UK P&P & £65 incl. ROW P&P
User avatar
GeoffSmith
Kitty Fiddler
 
Posts: 15344
Joined: Fri 03.02.2006, 21:57
Location: S2#417 in Tytherington, Gloucestershire

Re: I made a mistake

Postby Rambo » Tue 04.05.2021, 10:53

GeoffSmith wrote:
Rambo wrote:It does say ECM (turbo) though

It's only the turbo that has the sense line connected back from the fuel pump (I believe).


Don't ask me. I've got no electrical/electronics knowledge :wink:
Rambo
Don't push me
 
Posts: 8309
Joined: Wed 24.12.2003, 00:37
Location: Kelso

Re: I made a mistake

Postby dapinky » Tue 04.05.2021, 11:11

Ah,

I fully understood the 'atmo' term, but (in my mind) disregarded it when the conversation went to ECUs....

First, the ECU for an NA is quite different to the ECU for a turbo - it is far more basic inside - whilst the NA one cannot work with a turbo, I don't know if they would work the other way round - Geoff :poke:

Anyway, I do know that leaving the ignition switched on on my old cars (1970's) would cause the coil to get very hot, and eventually fail......

..... is it a possibility that the NA ECU would allow current to still go to the coil in these circumstances, and cause a failure there??? I really have little knowledge of the system on an NA, and suggest it purely because it was a common failure on a Mk3 Cortina!
Dave

Just the one now, but this one's mine! - and it will be finished eventually.....

go on - click this link - you know you want to!
User avatar
dapinky
LEC Administrator
 
Posts: 9056
Joined: Sun 15.10.2006, 12:54
Location: As far west as you can get in West Wales before you become Irish (Pembroke Dock).

Re: I made a mistake

Postby tangara » Tue 04.05.2021, 12:50

It was my first thought: ignition but as I turn ignition switch on there are sparks on the plugs.
I have the fuel pump connection diagram and NO +12v with white and light green incoming signal for the relay.
Will have a look at fuse A5 and M relay (
tangara
Newbie
 
Posts: 11
Joined: Sun 04.10.2020, 12:38
Location: 5351 hAILLOT bELGIUM

Re: I made a mistake

Postby Saltire » Tue 04.05.2021, 13:44

dapinky wrote:. . . purely because it was a common failure on a Mk3 Cortina!

In my experience pretty much everything was a common failure on a Mk3 Cortina :shock:
Jonathan

1995 Elan S2 no 512, BRG/magnolia, last of 4 UK S2 to this spec
2019 VW Golf R - “The Flying Tomato”
2020 Volvo XC40 T4 AWD
User avatar
Saltire
God
 
Posts: 1830
Joined: Sun 05.04.2015, 22:27
Location: Left foot in Wiltshire, right foot in Gloucestershire, heart in Scotland

Re: I made a mistake

Postby tangara » Tue 04.05.2021, 14:42

GOT IT ! IT runs
relay M defect ......
thank you to all of you for the help

Thierry
tangara
Newbie
 
Posts: 11
Joined: Sun 04.10.2020, 12:38
Location: 5351 hAILLOT bELGIUM

Re: I made a mistake

Postby Rambo » Tue 04.05.2021, 15:13

Well done Thierry :smt023
Rambo
Don't push me
 
Posts: 8309
Joined: Wed 24.12.2003, 00:37
Location: Kelso

Re: I made a mistake

Postby Saltire » Tue 04.05.2021, 16:03

tangara wrote:GOT IT ! IT runs
relay M defect ......
thank you to all of you for the help

Thierry

Great news! :clap:
Jonathan

1995 Elan S2 no 512, BRG/magnolia, last of 4 UK S2 to this spec
2019 VW Golf R - “The Flying Tomato”
2020 Volvo XC40 T4 AWD
User avatar
Saltire
God
 
Posts: 1830
Joined: Sun 05.04.2015, 22:27
Location: Left foot in Wiltshire, right foot in Gloucestershire, heart in Scotland

Previous

Return to Engine Ancillaries

Who is online

Users browsing this forum: No registered users and 2 guests