Fuel Pump does not turn off after 2 seconds

Moderators: theelanman, dapinky, Nige, Elanlover, Sy V, muley, Enright, algirdas, nitroman, GeoffSmith, clemo, Dave Eds, Specky, DaveT

Fuel Pump does not turn off after 2 seconds

Postby 378S2 » Mon 31.05.2021, 15:52

Hello - my S2 had some problems with the wiring of the fuel pump caused by a dodgy repair some time ago. I have fixed it and returned the loom to OEM condition. However, when I turn the ignition on and don’t start the engine the pump runs continuously rather than turning off after 2 seconds.

I’ve checked the basics and the ECU is getting the ‘pump on’ signal. The car runs beautifully, no faults.

Does anyone have experience of a similar fault condition and / or advice on how to troubleshoot or what to check?

Thank you very much
George
User avatar
378S2
Enthusiast
 
Posts: 143
Joined: Wed 09.09.2020, 02:19
Location: Perth, Western Australia

Re: Fuel Pump does not turn off after 2 seconds

Postby GeoffSmith » Mon 31.05.2021, 15:58

The fuel pump is controlled by and monitors the fuel pump relay.
http://wikilec.com/images/e/e9/MJ25-05_Fuel_Pump.gif
Calypso Red S2 #417

USB ElanScan interfaces - £60 incl. UK P&P & £65 incl. ROW P&P
User avatar
GeoffSmith
Kitty Fiddler
 
Posts: 15392
Joined: Fri 03.02.2006, 21:57
Location: S2#417 in Tytherington, Gloucestershire

Re: Fuel Pump does not turn off after 2 seconds

Postby 378S2 » Tue 01.06.2021, 01:33

Hi Geoff, thank you. I have reinstated everything from the +ve post to pin 3 on the pump relay and the pump is once again controlled by ECM A1. I’ve checked that ECM B2 is getting the power on signal.

I have not yet traced the wiring all the way to the pump (I found they had chopped it at the ECU harness) so I will do that next.

Do you know of any other faults that could cause it to stay on? I have no engine fault codes stored.

Thanks
George
User avatar
378S2
Enthusiast
 
Posts: 143
Joined: Wed 09.09.2020, 02:19
Location: Perth, Western Australia

Re: Fuel Pump does not turn off after 2 seconds

Postby WayneA » Sun 06.06.2021, 15:44

Taken from the manual…

“When the ignition is switched on, the ECM energizes the fuel pump which will continue to run for as long as the ECM receives ignition pulses from the ignition module (engine cranking or running). If no ignition pulses are received, the ECM will continue to run the pump for about two seconds before switching off the feed.”

If the pump is running more than 2 seconds you have one or more problems. The relay is stuck (bad) or the ECU is bad (thinks the engine is running).

How do you know the pump is running for more than 2 seconds? Do you hear it? Are you back probing it and checking for voltage?

Check that the White/Light Green wire is supplying 12v to the relay from the ECU. Check that the White/Green wire is 12v at the ECU. If the W/G wire has 12v at the ECU, the ECU is bad or not wired correctly.
WayneA
Newbie
 
Posts: 6
Joined: Thu 08.10.2020, 12:43

Re: Fuel Pump does not turn off after 2 seconds

Postby 378S2 » Thu 10.06.2021, 11:49

Thank you.
User avatar
378S2
Enthusiast
 
Posts: 143
Joined: Wed 09.09.2020, 02:19
Location: Perth, Western Australia


Return to Electrical / Electronics / Stereo / Lights etc.

Who is online

Users browsing this forum: No registered users and 1 guest