Page 6 of 6

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Tue 27.07.2021, 17:56
by TorqueHorse
:clap: Awesome to see Steve having fun, and looking good doing it!

BTW, I totally used the gearbox dipstick trick after seeing your post (esp. helpful since I think one of the reference sources quotes the wrong full capacity), thx!

And, I forgot to ask how do you start the siphon for your patented coolant slurper upper?
Image

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Wed 28.07.2021, 14:24
by 378S2
I’m glad the dipstick was useful! But I can’t claim ownership of that one, DaPinky recommended it and I took his excellent advice.

Coolant slurper upper... The fiddly part is getting the hose all the way down to the bottom of the radiator. I had a large syringe that I used for making a vacuum brake bleeder lying around so I used that.

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Mon 16.08.2021, 11:02
by 378S2
I’ve put a few miles on the clock since fixing the secondary throttle, and in case this is relevant for anyone else - the problem I had with soot on the rear bumper appears to be completely resolved (not wishing to anger the Lotus Gods there by declaring a victory - please don’t strike me down with great vengeance and a furious HGF).

Apart from the soot being gone, no noticeable performance benefits that I can comment on. They may be there but I haven’t noticed them.

Everything else… appears to be… fine. Which is quite an odd feeling. So to keep me busy I’ll rebuild the proportioning valves with the o-rings Matt kindly sent and swap over the MBC for the updated one. That’s sure to result in some scope creep.

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Tue 24.08.2021, 06:01
by 378S2
Back to the major repairs:

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Thu 26.08.2021, 04:06
by TorqueHorse
Mustang?! Are you trying to make an assemblage of all the great historical convertibles in one go? I thought if you were going for the ball knob, you'd have gone with like an esprit S2(?) wood one

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Fri 27.08.2021, 00:54
by 378S2
Yea... I am not sure they fit the look of the car. I am not sure my Mustang one does either, but in my defence I was being forced to watch something terrible on Netflix one night (some sort of cooking themed 'celebrity' singing on ice death match) and eBay made me do it.

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Fri 27.08.2021, 04:13
by TorqueHorse
Oh man don't get me started. I do the rounds from ebay, to BAT, to Cars and Bids, seemingly everyday and it is a miracle that I don't have 5 esprits, 3 elans, an SLK, an MR2, a TR6, and a Z4 sitting in my lawn too. Call yourself lucky with a simple splurge :)

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Sun 19.09.2021, 11:47
by 378S2
I had a very enjoyable and pretty long (400km) run out with the Lotus Club today. I’m quite a bit slower than the pack, but it’s my driving rather than the car!

My boost now hits the 0.65bar max, but it is odd because I can only get it there when I am accelerating between 100kmh and 120kmh in 5th gear. That’s ~2800rpm to ~4000rpm. I can't get it to work in any other gear and it doesn’t work in 5th every time. It routinely gets to 0.5bar in all gears no problems. So it is a bit odd...

Is it normal to be speed dependent or do I have a loose wire to find? Any likely culprits? Sadly no Elan scan to offer as I am a Mac user and haven’t got around to borrowing a PC yet. My throttle cable is at max adjustment, could it be that it is not quite hitting 100%?

Any tips very welcome.

79F92B8E-C384-409B-BE43-5264FB3622EB.jpeg
What I lack in speed I make up for in pop up headlights, which everyone knows are cool.
9768E0F4-0495-4AFC-A7B2-5D62CA559BBC.jpeg
Side angle - the paps were out in force today.
5540B4EB-4EAD-4E4D-8F55-1778AFABAABD.jpeg
Nice place for a drive.
533AAA5C-6838-450E-99C7-9F30159815C4.jpeg
It rained a little, but as long as you don't stop you don't get wet.
BEDD51D8-9C2C-43DA-9D2F-ED1732759962.jpeg
The car is running beautifully. I did need a push start today, but only because of some dodgy wiring on the immobiliser that I’ll fix when I get a moment.
6BC98491-51EF-496C-8F72-54E584F0298A.jpeg
A wee bit embarrassing. My immobiliser only immobilises the starter, and it refused to mobilise it after a short stop. The problem turned out to be more twisted together wires wrapped up in tape. If wiring isn’t your thing, please don’t do it. Sadly this immobiliser was professionally installed at the cost of a previous owner, and that is pretty unforgivable if you do this stuff for a living.

Re: S2 #378 (Steve) - hopefully only light fixes

PostPosted: Mon 20.09.2021, 14:31
by Simon_P
378S2 wrote:It routinely gets to 0.5bar in all gears no problems. So it is a bit odd...

That's normal you only get the extra bit under certain conditions. Also the secondary throttle doesn't open until 4700 rpm so if you're driving around at 2-4000 rpm about the only thing opening is the thermostat.